[trunk/include/autotools.mk] disable libtool fixups in trunk globally
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Dec 2010 00:11:09 +0000 (00:11 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Dec 2010 00:11:09 +0000 (00:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24234 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index 1ddb49b..7e251ea 100644 (file)
@@ -49,17 +49,18 @@ define remove_version_check
        fi
 endef
 
-ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool remove_version_check
-  Hooks/Configure/Post += update_libtool
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
-
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-  Hooks/Configure/Post += update_libtool_ucxx
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
+# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
+# ifneq ($(filter libtool,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool remove_version_check
+#   Hooks/Configure/Post += update_libtool
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif
+# 
+# ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
+#   Hooks/Configure/Post += update_libtool_ucxx
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif