ramips: add support for Argus ATP-52B
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Aug 2011 14:11:45 +0000 (14:11 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Aug 2011 14:11:45 +0000 (14:11 +0000)
[The ESW related changes has been removed - juhosg]

Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27991 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-argus-atp52b.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39

index 405e7c4..1ffa790 100644 (file)
@@ -41,6 +41,7 @@ case "$FIRMWARE" in
                rt2x00_eeprom_extract "devconf" 0 272
                ;;
 
+       argus-atp52b | \
        f5d8235v2 | \
        fonera20n | \
        hw550-3g | \
index 33ce13c..616e966 100755 (executable)
@@ -10,6 +10,9 @@ ramips_board_name() {
        machine=$(awk 'BEGIN{FS="[ \t]+:[ \t]"} /machine/ {print $2}' /proc/cpuinfo)
 
        case "$machine" in
+       *"Argus ATP-52B")
+               name="argus-atp52b"
+               ;;
        *"Aztech HW550-3G")
                name="hw550-3g"
                ;;
index 8571f7a..baaff71 100644 (file)
@@ -25,6 +25,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_NW718,              /* Netcore NW718 */
 
        /* RT3052 based machines */
+       RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
index c24670e..36b1515 100644 (file)
@@ -2,6 +2,12 @@ if RALINK_RT305X
 
 menu "Ralink RT350x machine selection"
 
+config RT305X_MACH_ARGUS_ATP52B
+       bool "Argus ATP-52B support"
+       default y
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_RT_G32_REVB
        bool "Asus RT-G32 revB board support"
        default y
index 2b1c59e..75f4782 100644 (file)
@@ -11,6 +11,7 @@ obj-y := irq.o setup.o devices.o rt305x.o clock.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
+obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-argus-atp52b.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-argus-atp52b.c
new file mode 100644 (file)
index 0000000..bee06fd
--- /dev/null
@@ -0,0 +1,114 @@
+/*
+ *  Argus ATP-52B router support
+ *  http://www.argus-co.com/english/productsview.php?id=70&cid=81
+ *
+ *  Copyright (C) 2011 Roman Yeryomin <roman@advem.lv>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define ARGUS_ATP52B_GPIO_LED_RUN              9
+#define ARGUS_ATP52B_GPIO_LED_NET              13
+#define ARGUS_ATP52B_GPIO_BUTTON_WPS           0
+#define ARGUS_ATP52B_GPIO_BUTTON_RESET         10
+#define ARGUS_ATP52B_BUTTONS_POLL_INTERVAL     20
+
+static struct gpio_led argus_atp52b_leds_gpio[] __initdata = {
+       {
+               .name       = "argus_atp52b:green:run",
+               .gpio       = ARGUS_ATP52B_GPIO_LED_RUN,
+               .active_low = 1,
+       },
+       {
+               .name       = "argus_atp52b:amber:net",
+               .gpio       = ARGUS_ATP52B_GPIO_LED_NET,
+               .active_low = 1,
+       }
+};
+
+static struct gpio_button argus_atp52b_gpio_buttons[] __initdata = {
+       {
+               .desc       = "wps",
+               .type       = EV_KEY,
+               .code       = KEY_WPS_BUTTON,
+               .threshold  = 3,
+               .gpio       = ARGUS_ATP52B_GPIO_BUTTON_WPS,
+               .active_low = 1,
+       },
+       {
+               .desc       = "reset",
+               .type       = EV_KEY,
+               .code       = KEY_RESTART,
+               .threshold  = 10,
+               .gpio       = ARGUS_ATP52B_GPIO_BUTTON_RESET,
+               .active_low = 1,
+       }
+};
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition argus_atp52b_partitions[] = {
+       {
+               .name   = "bootloader",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "config",
+               .offset = 0x030000,
+               .size   = 0x010000,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x120000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x170000,
+               .size   = 0x680000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data argus_atp52b_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(argus_atp52b_partitions),
+       .parts          = argus_atp52b_partitions,
+#endif
+};
+
+static void __init argus_atp52b_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+       rt305x_register_flash(0, &argus_atp52b_flash_data);
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(argus_atp52b_leds_gpio),
+                                       argus_atp52b_leds_gpio);
+       ramips_register_gpio_buttons(-1, ARGUS_ATP52B_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(argus_atp52b_gpio_buttons),
+                                       argus_atp52b_gpio_buttons);
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_ARGUS_ATP52B, "ARGUS_ATP52B", "Argus ATP-52B",
+                                       argus_atp52b_init);
index 6954399..bbbf0e6 100644 (file)
@@ -199,6 +199,18 @@ define Image/Build/Profile/WCR150GN
 endef
 
 
+mtdlayout_argus_atp52b=mtdparts=physmap-flash.0:192k(bootloader)ro,64k(config),64k(factory),1152k(kernel),6656k(rootfs),7808k@0x50000(firmware)
+mtd_argus_atp52b_kernel_part_size=1179648
+mtd_argus_atp52b_rootfs_part_size=6815744
+define Image/Build/Template/ARGUS_ATP52B
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_argus_atp52b,$(mtd_argus_atp52b_kernel_part_size),$(mtd_argus_atp52b_rootfs_part_size))
+endef
+
+define Image/Build/Profile/ARGUS_ATP52B
+       $(call Image/Build/Template/ARGUS_ATP52B,$(1),argus_atp52b,ARGUS_ATP52B)
+endef
+
+
 mtdlayout_f5d8235=mtdparts=physmap-flash.0:320k(u-boot)ro,1536k(kernel),6208k(rootfs),64k(nvram),64k(factory),7744k@0x50000(firmware)
 mtd_f5d8235_kernel_part_size=1572864
 mtd_f5d8235_rootfs_part_size=6356992
@@ -213,6 +225,7 @@ endef
 
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
index bd8887b..5357652 100644 (file)
@@ -91,6 +91,7 @@ CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y
 CONFIG_RAMIPS_WDT=y
+CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
 CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y