madwifi: change the network scripts to use the new wds sta separation feature
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 05:22:16 +0000 (05:22 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 05:22:16 +0000 (05:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12005 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Makefile
package/madwifi/files/etc/hotplug.d/net/10-madwifi [new file with mode: 0644]
package/madwifi/files/lib/wifi/madwifi.sh

index 48fa28e..97516e4 100644 (file)
@@ -214,9 +214,8 @@ define Build/InstallDev
 endef
 
 define KernelPackage/madwifi/install
-       $(INSTALL_DIR) $(1)/lib/wifi
-       $(INSTALL_DATA) ./files/lib/wifi/madwifi.sh $(1)/lib/wifi
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) ./files/* $(1)/
        $(CP) $(PKG_BUILD_DIR)/tools/{madwifi_multi,$(MADWIFI_APPLETS)} $(1)/usr/sbin/
 endef
 
diff --git a/package/madwifi/files/etc/hotplug.d/net/10-madwifi b/package/madwifi/files/etc/hotplug.d/net/10-madwifi
new file mode 100644 (file)
index 0000000..f5afce3
--- /dev/null
@@ -0,0 +1,12 @@
+if [ "$ACTION" = "add" -o "$ACTION" = "register" ]; then
+       case "$INTERFACE" in
+               ath*.sta*)
+                       local BASEIF="${INTERFACE%%\.*}"
+
+                       include /lib/network
+                       scan_interfaces
+                       local CONFIG="$(find_config "$BASEIF")" 
+                       [ -n "$CONFIG" ] && setup_interface "$INTERFACE" "$CONFIG"
+               ;;
+       esac
+fi
index 5a47f70..fe1e582 100755 (executable)
@@ -120,6 +120,9 @@ enable_atheros() {
                        iwpriv "$ifname" ff "$ff"
                fi
 
+               config_get wdssep "$vif" wdssep
+               [ -n "$wdssep" ] && iwpriv "$ifname" wdssep "$wdssep"
+
                config_get wds "$vif" wds
                case "$wds" in
                        1|on|enabled) wds=1;;