brcm47xx: image: create standard TRX images using new building system
authorrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Mar 2016 21:31:34 +0000 (21:31 +0000)
committerrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Mar 2016 21:31:34 +0000 (21:31 +0000)
Apart from using our new building system there are 2 more changes:

1) Limit amount of images
So far we were generating all standard images (optimized one and two
with no loader) for every SUBTARGET. This is not needed, as e.g. the
only device requiring gzipped kernel is legacy Huawei E970.

2) Change output names
The new image building system requires specifying device name. This
forced picking some and resulted in:
openwrt-brcm47xx-$(SUBTARGET)-squashfs.trx
openwrt-brcm47xx-$(SUBTARGET)-squashfs-gz.trx
openwrt-brcm47xx-$(SUBTARGET)-squashfs-noloader-nodictionary.trx
becoming:
openwrt-brcm47xx-$(SUBTARGET)-standard-squashfs.trx
openwrt-brcm47xx-$(SUBTARGET)-standard-noloader-gz-squashfs.trx
openwrt-brcm47xx-$(SUBTARGET)-standard-noloader-nodictionarylzma-squashfs.trx

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49006 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/image/Makefile

index bbdb36b..a65e9e0 100644 (file)
@@ -141,6 +141,19 @@ define Device/Default
        IMAGE/trx := trx-with-loader
 endef
 
+define Device/standard
+endef
+
+define Device/standard-noloader-gz
+       KERNEL_NAME = vmlinux.gz
+       IMAGE/trx := trx-without-loader
+endef
+
+define Device/standard-noloader-nodictionarylzma
+       KERNEL_NAME = vmlinux-nodictionary.lzma
+       IMAGE/trx := trx-without-loader
+endef
+
 define Device/asus
        IMAGES := trx
        IMAGE/trx := trx-with-loader | asus-trx
@@ -209,6 +222,8 @@ ifeq ($(SUBTARGET),generic)
   # BCMA SoC with SSB WiFi
   $(eval $(call LinksysDevice,wrt610n-v2,610N,2.0.0))
   $(eval $(call LinksysDevice,e3000-v1,61XN,1.0.3))
+
+  TARGET_DEVICES += standard
 endif
 
 #################################################
@@ -300,6 +315,8 @@ ifeq ($(SUBTARGET),legacy)
   $(eval $(call NetgearDevice,wgr614-v8,U12H072T00_NETGEAR,2))
   $(eval $(call NetgearDevice,wndr3300-v1,U12H093T00_NETGEAR,2))
   $(eval $(call NetgearDevice,wnr834b-v2,U12H081T00_NETGEAR,2))
+
+  TARGET_DEVICES += standard standard-noloader-gz
 endif
 
 #################################################
@@ -359,6 +376,8 @@ ifeq ($(SUBTARGET),mips74k)
 #  $(eval $(call NetgearDevice,wnr3500u,U12H136T00_NETGEAR,2))
   $(eval $(call NetgearDevice,wnr3500-v2,U12H127T00_NETGEAR,2))
 #  $(eval $(call NetgearDevice,wnr3500-v2-vc,U12H127T70_NETGEAR,2))
+
+  TARGET_DEVICES += standard standard-noloader-nodictionarylzma
 endif
 
 #################################################
@@ -379,21 +398,7 @@ endef
 
 # $(1): filesystem type.
 define Image/Build
-       $(STAGING_DIR_HOST)/bin/trx \
-               -m 33554432 \
-               -o $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx \
-               -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma \
-               $(call trxalign/$(1),$(1))
-       $(STAGING_DIR_HOST)/bin/trx \
-               -m 33554432 \
-               -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-noloader-nodictionary.trx \
-               -f $(KDIR)/vmlinux-nodictionary.lzma \
-               $(call trxalign/$(1),$(1))
-       $(STAGING_DIR_HOST)/bin/trx \
-               -m 33554432 \
-               -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-gz.trx \
-               -f $(KDIR)/vmlinux.gz \
-               $(call trxalign/$(1),$(1))
+       # TODO: Move it to Device/*
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
        $(call Image/Build/Initramfs)
 endif