sunxi: move rtc off to module
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Jan 2014 12:47:51 +0000 (12:47 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Jan 2014 12:47:51 +0000 (12:47 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39195 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/Makefile
target/linux/sunxi/config-3.12
target/linux/sunxi/modules.mk [new file with mode: 0644]

index cd936dc..0ababde 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=sunxi
 BOARDNAME:=Allwinner A1x/A20/A3x
-FEATURES:=fpu usb ext4 display
+FEATURES:=fpu usb ext4 display rtc
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
index d775c5d..a49d8ca 100644 (file)
@@ -350,8 +350,6 @@ CONFIG_RESOURCE_COUNTERS=y
 # CONFIG_RFKILL_REGULATOR is not set
 CONFIG_RFS_ACCEL=y
 CONFIG_RPS=y
-CONFIG_RTC_CLASS=y
-CONFIG_RTC_DRV_SUNXI=y
 CONFIG_SATA_AHCI_PLATFORM=y
 # CONFIG_SATA_RCAR is not set
 CONFIG_SCHED_HRTICK=y
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
new file mode 100644 (file)
index 0000000..8677a69
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define KernelPackage/rtc-sunxi
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=Sunxi SoC built-in RTC support
+    DEPENDS:=@TARGET_sunxi
+    $(call AddDepends/rtc)
+    KCONFIG:= \
+       CONFIG_RTC_CLASS=y \
+       CONFIG_RTC_DRV_SUNXI=m
+    FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
+    AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
+endef
+
+define KernelPackage/rtc-sunxi/description
+ Support for the AllWinner sunXi SoC's onboard RTC
+endef
+
+$(eval $(call KernelPackage,rtc-sunxi))
+