include: force a kernel-generated cpio removal and rebuild
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Jul 2013 20:52:00 +0000 (20:52 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Jul 2013 20:52:00 +0000 (20:52 +0000)
Make sure that the kernel rebuilds the initramfs cpio archive file by
deleting it before so we get it re-generated properly.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37125 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-defaults.mk

index ca520f5..607c821 100644 (file)
@@ -144,6 +144,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
 define Kernel/CompileImage/Initramfs
        $(call Kernel/Configure/Initramfs)
        $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),,rm -f $(TARGET_DIR)/init)
+       rm -rf $(KERNEL_BUILD_DIR)/usr/initramfs_data.cpio*
        +$(MAKE) $(KERNEL_MAKEOPTS) $(subst ",,$(KERNELNAME))
        #")
        #")