kernel: update kernel 3.18 to version 3.18.27
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Mar 2016 23:16:17 +0000 (23:16 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Mar 2016 23:16:17 +0000 (23:16 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48874 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.18/090-overlayfs-fallback-to-readonly-when-full.patch
target/linux/generic/patches-3.18/662-use_fq_codel_by_default.patch
target/linux/generic/patches-3.18/902-debloat_proc.patch
target/linux/generic/patches-3.18/903-debloat_direct_io.patch
target/linux/sunxi/patches-3.18/200-mmc-add-sdio-function-subnode.patch

index 3f4c71d..c159d10 100644 (file)
@@ -2,12 +2,12 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .26
+LINUX_VERSION-3.18 = .27
 LINUX_VERSION-4.1 = .16
 LINUX_VERSION-4.3 = .4
 LINUX_VERSION-4.4 = .3
 
-LINUX_KERNEL_MD5SUM-3.18.26 = fb3ef8da32a25607807887b9567a6927
+LINUX_KERNEL_MD5SUM-3.18.27 = 015a01bf84e7c6bc9952551b4da45044
 LINUX_KERNEL_MD5SUM-4.1.16 = e4bf22fed49b476b47acffc00c03267a
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 LINUX_KERNEL_MD5SUM-4.4.3 = 5feab5a2c016e186e3088d4fae963ed7
index 6fbbc25..1bcd515 100644 (file)
@@ -44,7 +44,7 @@ Miklos
 
 --- a/fs/overlayfs/copy_up.c
 +++ b/fs/overlayfs/copy_up.c
-@@ -300,6 +300,9 @@ int ovl_copy_up_one(struct dentry *paren
+@@ -311,6 +311,9 @@ int ovl_copy_up_one(struct dentry *paren
        struct cred *override_cred;
        char *link = NULL;
  
index ba7c384..5caf933 100644 (file)
@@ -51,7 +51,7 @@
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -737,7 +737,7 @@ static void attach_one_default_qdisc(str
+@@ -739,7 +739,7 @@ static void attach_one_default_qdisc(str
  
        if (dev->tx_queue_len) {
                qdisc = qdisc_create_dflt(dev_queue,
index 024efe0..79cecf9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/fs/locks.c
 +++ b/fs/locks.c
-@@ -2611,6 +2611,8 @@ static const struct file_operations proc
+@@ -2620,6 +2620,8 @@ static const struct file_operations proc
  
  static int __init proc_locks_init(void)
  {
index 92190e4..dbb08ca 100644 (file)
@@ -26,7 +26,7 @@
  endif
 --- a/include/linux/fs.h
 +++ b/include/linux/fs.h
-@@ -2528,12 +2528,25 @@ enum {
+@@ -2529,12 +2529,25 @@ enum {
        DIO_ASYNC_EXTEND = 0x04,
  };
  
index 96662d8..dcbb3a4 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
        put_device(&card->dev);
 --- a/drivers/mmc/core/core.c
 +++ b/drivers/mmc/core/core.c
-@@ -1207,6 +1207,34 @@ EXPORT_SYMBOL(mmc_of_parse_voltage);
+@@ -1231,6 +1231,34 @@ EXPORT_SYMBOL(mmc_of_parse_voltage);
  
  #endif /* CONFIG_OF */