[orion]: only copy uImages to the bin dir on ramdisk builds
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Jun 2013 06:17:12 +0000 (06:17 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Jun 2013 06:17:12 +0000 (06:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36851 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/orion/image/generic.mk

index c3aa50f..19daaf6 100644 (file)
@@ -82,7 +82,9 @@ define Image/BuildKernel/ARM/uImage
        '$(STAGING_DIR_HOST)/bin/mkimage' -A arm -O linux -T kernel \
        -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
        -d '$(KDIR)/$(1)-zImage' '$(KDIR)/$(1)-uImage'
+ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)  # only copy uImage for ramdisk build
        cp '$(KDIR)/$(1)-uImage' '$(BIN_DIR)/openwrt-$(1)-uImage'
+ endif
 endef
 
 define Image/BuildKernel/JFFS2uImage