ipv6-support: don't use disable_ipv6
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 17:25:43 +0000 (17:25 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jan 2013 17:25:43 +0000 (17:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35134 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/dhcpv6.sh

index 0d596d4..74286e7 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2013-01-02
+PKG_VERSION:=2013-01-13
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 9609f04..5a668cd 100755 (executable)
@@ -20,9 +20,8 @@ if [ "$state" == "started" ]; then
        conf_set "$device" accept_ra 2
        conf_set "$device" forwarding 2
 
-       # Trigger RS
-       conf_set "$device" disable_ipv6 1
-       conf_set "$device" disable_ipv6 0
+       # Send RS on interface
+       [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
 
        exit 0
 elif [ "$state" == "stopped" ]; then