kirkwood/goflexhome/goflexnet: merge "root" and unused mtd partitions into one volume...
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2016 17:06:14 +0000 (17:06 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2016 17:06:14 +0000 (17:06 +0000)
The kernel will automatic attach mtd partitions named 'ubi' to ubi0.
Renaming the "root" partition into "ubi" will safe arguments
from the kernel cmdline.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49014 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/patches-3.18/180-goflexhome.patch
target/linux/kirkwood/patches-3.18/181-goflexnet.patch [new file with mode: 0644]

index 0560073..e30a8b1 100644 (file)
@@ -1,5 +1,7 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
+Index: linux-3.18.27/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-3.18.27.orig/arch/arm/boot/dts/Makefile
++++ linux-3.18.27/arch/arm/boot/dts/Makefile
 @@ -120,6 +120,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += kirkwood-
        kirkwood-ds411.dtb \
        kirkwood-ds411j.dtb \
@@ -8,9 +10,11 @@
        kirkwood-goflexnet.dtb \
        kirkwood-guruplug-server-plus.dtb \
        kirkwood-ib62x0.dtb \
+Index: linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
+===================================================================
 --- /dev/null
-+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
-@@ -0,0 +1,127 @@
++++ linux-3.18.27/arch/arm/boot/dts/kirkwood-goflexhome.dts
+@@ -0,0 +1,117 @@
 +/dts-v1/;
 +
 +#include "kirkwood.dtsi"
 +      };
 +
 +      partition@100000 {
-+              label = "uImage";
-+              reg = <0x0100000 0x400000>;
-+      };
-+
-+      partition@500000 {
-+              label = "pogoplug";
-+              reg = <0x0500000 0x2000000>;
-+      };
-+
-+      partition@2500000 {
-+              label = "root";
-+              reg = <0x02500000 0xd800000>;
++              label = "ubi";
++              reg = <0x100000 0xfc00000>;
 +      };
 +};
 +
diff --git a/target/linux/kirkwood/patches-3.18/181-goflexnet.patch b/target/linux/kirkwood/patches-3.18/181-goflexnet.patch
new file mode 100644 (file)
index 0000000..9fe62d1
--- /dev/null
@@ -0,0 +1,25 @@
+Index: linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
+===================================================================
+--- linux-4.4.4.orig/arch/arm/boot/dts/kirkwood-goflexnet.dts
++++ linux-4.4.4/arch/arm/boot/dts/kirkwood-goflexnet.dts
+@@ -158,18 +158,8 @@
+       };
+       partition@100000 {
+-              label = "uImage";
+-              reg = <0x0100000 0x400000>;
+-      };
+-
+-      partition@500000 {
+-              label = "pogoplug";
+-              reg = <0x0500000 0x2000000>;
+-      };
+-
+-      partition@2500000 {
+-              label = "root";
+-              reg = <0x02500000 0xd800000>;
++              label = "ubi";
++              reg = <0x0100000 0xfc00000>;
+       };
+ };