build: extend menu with few ubifs options
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Oct 2013 10:49:47 +0000 (10:49 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Oct 2013 10:49:47 +0000 (10:49 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38303 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/image.mk

index 2074245..a7ef477 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -107,13 +107,47 @@ menu "Target Images"
                help
                  Build a squashfs-lzma root filesystem
 
-       config TARGET_ROOTFS_UBIFS
+       menuconfig TARGET_ROOTFS_UBIFS
                bool "ubifs"
                default y if USES_UBIFS
                depends on USES_UBIFS
                help
                  Build a ubifs root filesystem
 
+               choice
+                       prompt "compression"
+                       default TARGET_UBIFS_COMPRESSION_NONE
+                       depends on TARGET_ROOTFS_UBIFS
+                       help
+                         Select compression type
+
+                       config TARGET_UBIFS_COMPRESSION_NONE
+                               bool "none"
+
+                       config TARGET_UBIFS_COMPRESSION_LZO
+                               bool "lzo"
+
+                       config TARGET_UBIFS_COMPRESSION_ZLIB
+                               bool "zlib"
+               endchoice
+
+               config TARGET_UBIFS_FREE_SPACE_FIXUP
+                       bool "free space fixup" if TARGET_ROOTFS_UBIFS
+                       default y
+                       help
+                         The file-system free space has to be fixed up on first mount
+
+               config TARGET_UBIFS_JOURNAL_SIZE
+                       string
+                       prompt "journal size" if TARGET_ROOTFS_UBIFS
+                       default "512KiB"
+
+               config TARGET_UBIFS_SQUASH_UIDS
+                       bool "squash uids" if TARGET_ROOTFS_UBIFS
+                       default n
+                       help
+                         Squash owners making all files owned by root
+
        comment "Image Options"
 
        source "target/linux/*/image/Config.in"
index 5d512df..e0731f0 100644 (file)
@@ -116,7 +116,15 @@ endif
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
     define Image/mkfs/ubifs
                $(CP) ./ubinize.cfg $(KDIR)
-               $(STAGING_DIR_HOST)/bin/mkfs.ubifs $(UBIFS_OPTS) $(MKFS_DEVTABLE_OPT) -o $(KDIR)/root.ubifs -d $(TARGET_DIR)
+               $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
+                       $(UBIFS_OPTS) \
+                       $(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
+                       $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
+                       $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
+                       $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
+                       --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+                       -o $(KDIR)/root.ubifs \
+                       -d $(TARGET_DIR)
                $(call Image/Build,ubifs)
                (cd $(KDIR); \
                $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(KDIR)/root.ubi ubinize.cfg)