ramips: add profile for Allnet devices
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 12:36:35 +0000 (12:36 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 12:36:35 +0000 (12:36 +0000)
Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33225 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/rt305x/profiles/allnet.mk [new file with mode: 0644]

diff --git a/target/linux/ramips/rt305x/profiles/allnet.mk b/target/linux/ramips/rt305x/profiles/allnet.mk
new file mode 100644 (file)
index 0000000..2aab5e2
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALL02393G
+       NAME:=Allnet ALL0239-3G
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL02393G/Description
+       Package set for Allnet ALL0239-3G
+endef
+
+$(eval $(call Profile,ALL02393G))
+
+define Profile/ALL0256N
+       NAME:=Allnet ALL0256N
+       PACKAGES:=
+endef
+
+define Profile/ALL0256N/Description
+       Package set for Allnet ALL0256N
+endef
+
+$(eval $(call Profile,ALL0256N))
+
+define Profile/ALL5002
+       NAME:=Allnet ALL5002
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ALL5002/Description
+       Package set for Allnet ALL5002
+endef
+
+$(eval $(call Profile,ALL5002))