[package] base-files: add -h and --help options to sysupgrade (#9728)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 09:27:14 +0000 (09:27 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 09:27:14 +0000 (09:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27630 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 75883d8..d537ed3 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=74
+PKG_RELEASE:=75
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 3d76bb3..7efb2b4 100755 (executable)
@@ -10,6 +10,7 @@ export SAVE_CONFIG=1
 export SAVE_OVERLAY=0
 export DELAY=
 export CONF_IMAGE=
+export HELP=0
 
 # parse options
 while [ -n "$1" ]; do 
@@ -21,6 +22,7 @@ while [ -n "$1" ]; do
                -n) export SAVE_CONFIG=0;;
                -c) export SAVE_OVERLAY=1;;
                -f) export CONF_IMAGE="$2"; shift;;
+               -h|--help) export HELP=1; break;;
                -*)
                        echo "Invalid option: $1"
                        exit 1
@@ -36,7 +38,7 @@ export CONF_TAR=/tmp/sysupgrade.tgz
 export ARGV="$*"
 export ARGC="$#"
 
-[ -z "$ARGV" ] && {
+[ -z "$ARGV" -o $HELP -gt 0 ] && {
        cat <<EOF
 Usage: $0 [options] <image file or URL>
 
@@ -48,6 +50,7 @@ Options:
        -n           do not save configuration over reflash
        -q           less verbose
        -v           more verbose
+       -h / --help  display this help
 
 EOF
        exit 1