[kernel] add lm92 kernel module
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Apr 2013 10:00:40 +0000 (10:00 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Apr 2013 10:00:40 +0000 (10:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36181 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/hwmon.mk

index d549336..bc1f652 100644 (file)
@@ -134,6 +134,20 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm90))
 
+define KernelPackage/hwmon-lm92
+  TITLE:=LM92 monitoring support
+  KCONFIG:=CONFIG_SENSORS_LM92
+  FILES:=$(LINUX_DIR)/drivers/hwmon/lm92.ko
+  AUTOLOAD:=$(call AutoLoad,60,lm92)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm92/description
+ Kernel module for LM92 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm92))
+
 define KernelPackage/hwmon-lm95241
   TITLE:=LM95241 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM95241