lantiq: add esi
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Mar 2014 09:16:43 +0000 (09:16 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Mar 2014 09:16:43 +0000 (09:16 +0000)
http://patchwork.openwrt.org/patch/3703/

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40326 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/base-files/etc/init.d/esi [new file with mode: 0755]
target/linux/lantiq/xway/target.mk

diff --git a/target/linux/lantiq/base-files/etc/init.d/esi b/target/linux/lantiq/base-files/etc/init.d/esi
new file mode 100755 (executable)
index 0000000..5635b53
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2013 OpenWrt.org
+
+START=19
+start() {
+       esi $(printf '%X' $((1+0x$(tr -d : </sys/class/net/eth0/address)))) 2>/dev/null || :
+}
index 3da4638..1a8bbb4 100644 (file)
@@ -5,7 +5,7 @@ FEATURES:=squashfs atm mips16
 CPU_TYPE:=34kc
 CPU_SUBTYPE:=dsp
 
-DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug
+DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug atm-esi
 
 define Target/Description
        Lantiq XWAY