buildroot: make it easier to build all kmods
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Mar 2015 11:51:54 +0000 (11:51 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Mar 2015 11:51:54 +0000 (11:51 +0000)
Split out kmods from ALL to make it easier to create local builds that
are compatible kmod-wise with releases.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44830 3c298f89-4303-0410-b956-a3cf2f4a3e73

config/Config-build.in
include/version.mk
scripts/metadata.pl

index 213609b..582724e 100644 (file)
@@ -6,8 +6,12 @@
 
 menu "Global build settings"
 
+       config ALL_KMODS
+               bool "Select all kernel module packages by default"
+               default ALL
+
        config ALL
-               bool "Select all packages by default"
+               bool "Select all userspace packages by default"
                default n
 
        comment "General build options"
index 5cfeae2..69141ff 100644 (file)
@@ -53,7 +53,7 @@ $(lastword $(subst :, ,$(1)))
 endef
 
 VERSION_TAINT_SPECS := \
-       -ALL:no-all \
+       -ALL_KMODS:no-all \
        -IPV6:no-ipv6 \
        +USE_GLIBC:glibc \
        +USE_MKLIBS:mklibs \
index bfb9ab5..92923ea 100755 (executable)
@@ -545,7 +545,11 @@ sub print_package_config_category($) {
                        print "\t\t".($pkg->{tristate} ? 'tristate' : 'bool')." $title\n";
                        print "\t\tdefault y if DEFAULT_".$pkg->{name}."\n";
                        unless ($pkg->{hidden}) {
-                               $pkg->{default} ||= "m if ALL";
+                               if ($pkg->{name} =~ /^kmod-/) {
+                                       $pkg->{default} ||= "m if ALL_KMODS";
+                               } else {
+                                       $pkg->{default} ||= "m if ALL";
+                               }
                        }
                        if ($pkg->{default}) {
                                foreach my $default (split /\s*,\s*/, $pkg->{default}) {