openvpn: split easy-rsa into a separate package, it is no longer bundled with the...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Feb 2013 10:40:13 +0000 (10:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Feb 2013 10:40:13 +0000 (10:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35498 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/openvpn-easy-rsa/Makefile [new file with mode: 0644]
package/network/services/openvpn-easy-rsa/files/easy-rsa.index [new file with mode: 0644]
package/network/services/openvpn-easy-rsa/files/easy-rsa.serial [new file with mode: 0644]
package/network/services/openvpn/Makefile
package/network/services/openvpn/files/easy-rsa.index [deleted file]
package/network/services/openvpn/files/easy-rsa.serial [deleted file]

diff --git a/package/network/services/openvpn-easy-rsa/Makefile b/package/network/services/openvpn-easy-rsa/Makefile
new file mode 100644 (file)
index 0000000..c8a9788
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2010-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openvpn-easy-rsa
+
+PKG_REV:=ff5bfd1dd8e548cb24d302742af3894f893ef92f
+PKG_VERSION:=2012-01-30
+PKG_RELEASE=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/OpenVPN/easy-rsa.git
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/openvpn-easy-rsa
+  TITLE:=Simple shell scripts to manage a Certificate Authority
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=http://openvpn.net
+  SUBMENU:=VPN
+  DEPENDS:=+openssl-util
+endef
+
+define Package/openvpn-easy-rsa/conffiles
+/etc/easy-rsa/keys/serial
+/etc/easy-rsa/keys/index.txt
+/etc/easy-rsa/vars
+endef
+
+define Build/Configure
+
+endef
+
+define Build/Compile
+
+endef
+
+define Package/openvpn-easy-rsa/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/easy-rsa/2.0/{build-*,clean-all,inherit-inter,list-crl,pkitool,revoke-full,sign-req,whichopensslcnf} $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/easy-rsa
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/easy-rsa/2.0/openssl-1.0.0.cnf $(1)/etc/easy-rsa/openssl-1.0.0.cnf
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/easy-rsa/2.0/vars $(1)/etc/easy-rsa/vars
+       $(INSTALL_DIR) $(1)/etc/easy-rsa/keys
+       $(INSTALL_DATA) files/easy-rsa.index $(1)/etc/easy-rsa/keys/index.txt
+       $(INSTALL_DATA) files/easy-rsa.serial $(1)/etc/easy-rsa/keys/serial
+endef
+
+$(eval $(call BuildPackage,openvpn-easy-rsa))
diff --git a/package/network/services/openvpn-easy-rsa/files/easy-rsa.index b/package/network/services/openvpn-easy-rsa/files/easy-rsa.index
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/package/network/services/openvpn-easy-rsa/files/easy-rsa.serial b/package/network/services/openvpn-easy-rsa/files/easy-rsa.serial
new file mode 100644 (file)
index 0000000..8a0f05e
--- /dev/null
@@ -0,0 +1 @@
+01
index bba25cd..ad7a7ca 100644 (file)
@@ -48,19 +48,6 @@ Package/openvpn-openssl/config=$(call Package/openvpn/config/Default,openssl)
 Package/openvpn-polarssl/config=$(call Package/openvpn/config/Default,polarssl)
 Package/openvpn-nossl/config=$(call Package/openvpn/config/Default,nossl)
 
 Package/openvpn-polarssl/config=$(call Package/openvpn/config/Default,polarssl)
 Package/openvpn-nossl/config=$(call Package/openvpn/config/Default,nossl)
 
-define Package/openvpn-easy-rsa
-  $(call Package/openvpn)
-  DEPENDS:=+openssl-util
-  TITLE:=Simple shell scripts to manage a Certificate Authority
-endef
-
-define Package/openvpn-easy-rsa/conffiles
-/etc/easy-rsa/keys/serial
-/etc/easy-rsa/keys/index.txt
-/etc/easy-rsa/vars
-endef
-
-
 ifeq ($(BUILD_VARIANT),polarssl)
 CONFIG_OPENVPN_POLARSSL:=y
 endif
 ifeq ($(BUILD_VARIANT),polarssl)
 CONFIG_OPENVPN_POLARSSL:=y
 endif
@@ -131,18 +118,6 @@ define Package/openvpn-$(BUILD_VARIANT)/install
                $(1)/lib/upgrade/keep.d/openvpn
 endef
 
                $(1)/lib/upgrade/keep.d/openvpn
 endef
 
-define Package/openvpn-easy-rsa/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/easy-rsa/2.0/{build-*,clean-all,inherit-inter,list-crl,pkitool,revoke-full,sign-req,whichopensslcnf} $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/easy-rsa
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/easy-rsa/2.0/openssl-1.0.0.cnf $(1)/etc/easy-rsa/openssl-1.0.0.cnf
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/easy-rsa/2.0/vars $(1)/etc/easy-rsa/vars
-       $(INSTALL_DIR) $(1)/etc/easy-rsa/keys
-       $(INSTALL_DATA) files/easy-rsa.index $(1)/etc/easy-rsa/keys/index.txt
-       $(INSTALL_DATA) files/easy-rsa.serial $(1)/etc/easy-rsa/keys/serial
-endef
-
 $(eval $(call BuildPackage,openvpn-openssl))
 $(eval $(call BuildPackage,openvpn-polarssl))
 $(eval $(call BuildPackage,openvpn-nossl))
 $(eval $(call BuildPackage,openvpn-openssl))
 $(eval $(call BuildPackage,openvpn-polarssl))
 $(eval $(call BuildPackage,openvpn-nossl))
-$(eval $(call BuildPackage,openvpn-easy-rsa))
diff --git a/package/network/services/openvpn/files/easy-rsa.index b/package/network/services/openvpn/files/easy-rsa.index
deleted file mode 100644 (file)
index e69de29..0000000
diff --git a/package/network/services/openvpn/files/easy-rsa.serial b/package/network/services/openvpn/files/easy-rsa.serial
deleted file mode 100644 (file)
index 8a0f05e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-01