map: export calculated ruleset to /tmp
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2015 19:00:39 +0000 (19:00 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 13 Jan 2015 19:00:39 +0000 (19:00 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43961 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh

index 2848fe9..ed358de 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 83de4cc..945accd 100755 (executable)
@@ -52,6 +52,7 @@ proto_map_setup() {
                fi
        fi
 
+       echo "rule=$rule" > /tmp/map-$cfg.rules
        RULE_DATA=$(mapcalc ${tunlink:-\*} $rule)
        if [ "$?" != 0 ]; then
                proto_notify_error "$cfg" "INVALID_MAP_RULE"
@@ -59,6 +60,7 @@ proto_map_setup() {
                return
        fi
 
+       echo "$RULE_DATA" >> /tmp/map-$cfg.rules
        eval $RULE_DATA
        
        if [ -z "$RULE_BMR" ]; then
@@ -188,6 +190,7 @@ proto_map_setup() {
 proto_map_teardown() {
        local cfg="$1"
        ifdown "${cfg}_local"
+       rm -f /tmp/map-$cfg.rules
 }
 
 proto_map_init_config() {