update acx100
authormatteo <matteo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Feb 2008 20:30:28 +0000 (20:30 +0000)
committermatteo <matteo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Feb 2008 20:30:28 +0000 (20:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10439 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/acx/Makefile
package/acx/patches/001-build-fix.diff [deleted file]
package/acx/patches/003-2.6.24-compat.diff [deleted file]

index 216df5f..c61bf2d 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx
-PKG_VERSION:=20080112
+PKG_VERSION:=20080210
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/acx100
-PKG_MD5SUM:=b376b5359ef15da589ef17387a6b37d3
+PKG_MD5SUM:=7d5ce3215708e4e9f95cf567a9ee3a12
 
 PKG_FW_NAME:=tiacx111c16
 PKG_FW_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
diff --git a/package/acx/patches/001-build-fix.diff b/package/acx/patches/001-build-fix.diff
deleted file mode 100644 (file)
index b21893f..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- 20080112/pci.c     2008/01/12 12:16:53     8
-+++ 20080112/pci.c     2008/01/12 20:10:36     9
-@@ -2060,7 +2060,7 @@
-       /* then wait until interrupts have finished executing on other CPUs */
-       acx_lock(adev, flags);
-       disable_acx_irq(adev);
--      synchronize_irq(adev->irq);
-+      synchronize_irq(adev->pdev->irq);
-       acx_unlock(adev, flags);
-       /* we really don't want to have an asynchronous tasklet disturb us
-
diff --git a/package/acx/patches/003-2.6.24-compat.diff b/package/acx/patches/003-2.6.24-compat.diff
deleted file mode 100644 (file)
index c216dd1..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -u acx-20080112/pci.c acx-20080112.new/pci.c
---- acx-20080112/pci.c 2008-02-08 19:20:41.000000000 +0000
-+++ acx-20080112.new/pci.c     2008-02-08 19:05:46.000000000 +0000
-@@ -1632,7 +1632,7 @@
-       acx_show_card_eeprom_id(adev);
- #endif /* NONESSENTIAL_FEATURES */
--#ifdef SET_MODULE_OWNER
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)) && defined(SET_MODULE_OWNER)
-       SET_MODULE_OWNER(ndev);
- #endif
-       SET_NETDEV_DEV(ndev, &pdev->dev);
-@@ -2128,7 +2128,7 @@
- /* TODO: pci_set_power_state(pdev, PCI_D0); ? */
-       /* request shared IRQ handler */
--      if (request_irq(ndev->irq, acxpci_i_interrupt, SA_SHIRQ, ndev->name, ndev)) {
-+      if (request_irq(ndev->irq, acxpci_i_interrupt, IRQF_SHARED, ndev->name, ndev)) {
-               printk("%s: request_irq FAILED\n", ndev->name);
-               result = -EAGAIN;
-               goto done;
-@@ -4339,7 +4339,7 @@
-         acx_show_card_eeprom_id(adev);
- #endif /* NONESSENTIAL_FEATURES */
--#ifdef SET_MODULE_OWNER
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24)) && defined(SET_MODULE_OWNER)
-         SET_MODULE_OWNER(ndev);
- #endif
-         SET_NETDEV_DEV(ndev, adev->bus_dev);
-diff -u acx-20080112/usb.c acx-20080112.new/usb.c
---- acx-20080112/usb.c 2008-01-12 12:27:38.000000000 +0000
-+++ acx-20080112.new/usb.c     2008-02-08 19:01:34.000000000 +0000
-@@ -859,7 +859,9 @@
-       ndev->watchdog_timeo = 4 * HZ;
- #endif
-       ndev->change_mtu = &acx_e_change_mtu;
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
-       SET_MODULE_OWNER(ndev);
-+#endif
-       /* Setup private driver context */