[toolchain] if CONFIG_BUILD_NLS is selected, compile uClibc with locale support
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jan 2012 15:11:11 +0000 (15:11 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Jan 2012 15:11:11 +0000 (15:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29633 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
toolchain/uClibc/Makefile

index 901d740..4e874a6 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -145,7 +145,7 @@ menu "Global build settings"
                bool "Compile with full language support"
                help
                  When this option is enabled, packages are built with the full versions of iconv and GNU gettext
-                 instead of the default OpenWrt stubs.
+                 instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
 
        config SHADOW_PASSWORDS
                bool
index 5f4ddb5..8c65844 100644 (file)
@@ -78,6 +78,7 @@ define Host/Prepare
                -e 's,^.*UCLIBC_HAS_FPU.*,UCLIBC_HAS_FPU=$(if $(CONFIG_SOFT_FLOAT),n,y),g' \
                -e 's,^.*UCLIBC_HAS_SOFT_FLOAT.*,UCLIBC_HAS_SOFT_FLOAT=$(if $(CONFIG_SOFT_FLOAT),y,n),g' \
                -e 's,^.*UCLIBC_HAS_SHADOW.*,UCLIBC_HAS_SHADOW=$(if $(CONFIG_SHADOW_PASSWORDS),y,n),g' \
+               -e 's,^.*UCLIBC_HAS_LOCALE.*,UCLIBC_HAS_LOCALE=$(if $(CONFIG_BUILD_NLS),y,n),g' \
                $(HOST_BUILD_DIR)/.config
        $(MAKE) -C $(HOST_BUILD_DIR) oldconfig KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"
        $(MAKE) -C $(HOST_BUILD_DIR)/extra/config conf KBUILD_HAVE_NLS= HOSTCFLAGS="-DKBUILD_NO_NLS"