iproute2: re-enable PIC, it is only applied to libnetlink.a and required for collectd
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Jul 2014 12:41:36 +0000 (12:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Jul 2014 12:41:36 +0000 (12:41 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41460 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iproute2/Makefile

index 558855f..fc47159 100644 (file)
@@ -86,7 +86,7 @@ MAKE_FLAGS += \
        SHARED_LIBS="" \
        LDFLAGS="-Wl,--gc-sections" \
        IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
-       FPIC=""
+       FPIC="$(FPIC)"
 
 define Build/Compile
        +$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS)