ar71xx: add a profile and build images for the TL-WR2543N/ND
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Jan 2012 19:36:42 +0000 (19:36 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Jan 2012 19:36:42 +0000 (19:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29682 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 2b9aa0e..8f1314a 100644 (file)
@@ -136,3 +136,14 @@ define Profile/TLWR1043/Description
        Package set optimized for the TP-LINK TL-WR1043N/ND.
 endef
 $(eval $(call Profile,TLWR1043))
+
+
+define Profile/TLWR2543
+       NAME:=TP-LINK TL-WR2543N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR2543/Description
+       Package set optimized for the TP-LINK TL-WR2543N/ND.
+endef
+$(eval $(call Profile,TLWR2543))
index 72c5bd6..62a6fb2 100644 (file)
@@ -854,6 +854,11 @@ define Image/Build/Profile/TLWR1043
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043_cmdline),0x10430001,1,8M)
 endef
 
+tlwr2543_cmdline=board=TL-WR2543N console=ttyS0,115200
+define Image/Build/Profile/TLWR2543
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma)
+endef
+
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
@@ -970,6 +975,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841,$(1))
        $(call Image/Build/Profile/TLWR941,$(1))
        $(call Image/Build/Profile/TLWR1043,$(1))
+       $(call Image/Build/Profile/TLWR2543,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
        $(call Image/Build/Profile/WNDR3700,$(1))