kernel: make sound-soc-core depend on kmod-ac97
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 21:12:04 +0000 (21:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 21:12:04 +0000 (21:12 +0000)
it has a conditional #ifdef based dependency on it, which trips up on
some targets

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38242 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/sound.mk

index 0dae819..ff0cc08 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call KernelPackage,sound-cs5535audio))
 
 define KernelPackage/sound-soc-core
   TITLE:=SoC sound support
-  DEPENDS:=+kmod-regmap
+  DEPENDS:=+kmod-regmap +kmod-ac97
   KCONFIG:= \
        CONFIG_SND_SOC \
        CONFIG_SND_SOC_DMAENGINE_PCM=y \