gettext-full: use portability header files for byteswapping on non-linux systems
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Jul 2013 14:49:20 +0000 (14:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 6 Jul 2013 14:49:20 +0000 (14:49 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37186 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/gettext-full/Makefile

index 7b640e6..11dc1f5 100644 (file)
@@ -35,6 +35,9 @@ define Package/libintl-full
 endef
 
 TARGET_CFLAGS += $(FPIC)
+ifneq ($(HOST_OS),Linux)
+  TARGET_CFLAGS += -I$(STAGING_DIR_HOST)/include
+endif
 
 CONFIGURE_ARGS += \
        --enable-shared \