add missing -prepare target
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2007 19:04:23 +0000 (19:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2007 19:04:23 +0000 (19:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7017 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index f5ff856..9a64188 100644 (file)
@@ -26,9 +26,9 @@ ifeq ($(QUIET),1)
 %-compile %-install: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
 
-%-prereq %-download %-clean: FORCE
+%-prepare %-prereq %-download %-clean: FORCE
 else
-%-prereq %-download %-clean %-compile %-install: FORCE
+%-prepare %-prereq %-download %-clean %-compile %-install: FORCE
 endif
        $(MAKE) -C $* $(patsubst $*-%,%,$@)