Add fakeidentd a lightweight identd daemon.
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Apr 2006 14:12:04 +0000 (14:12 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Apr 2006 14:12:04 +0000 (14:12 +0000)
Fix minor typo in menuconfig for weechat

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3631 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/fakeidentd/Config.in [new file with mode: 0644]
package/fakeidentd/Makefile [new file with mode: 0644]
package/fakeidentd/files/fakeidentd.init [new file with mode: 0644]
package/fakeidentd/ipkg/fakeidentd.control [new file with mode: 0644]
package/weechat/Config.in

index 8cea289..3a123aa 100644 (file)
@@ -85,6 +85,7 @@ source "package/elhttp/Config.in"
 source "package/ether-wake/Config.in"
 source "package/ethtool/Config.in"
 source "package/ez-ipupdate/Config.in"
+source "package/fakeidentd/Config.in"
 source "package/fping/Config.in"
 source "package/fprobe/Config.in"
 source "package/fprobe-ulog/Config.in"
index 4da2eb1..4d0f004 100644 (file)
@@ -49,6 +49,7 @@ package-$(BR2_PACKAGE_ELINKS) += elinks
 package-$(BR2_PACKAGE_ETHER_WAKE) += ether-wake
 package-$(BR2_COMPILE_EXPAT) += expat
 package-$(BR2_PACKAGE_EZIPUPDATE) += ez-ipupdate
+package-$(BR2_PACKAGE_FAKEIDENTD) += fakeidentd
 package-$(BR2_PACKAGE_FETCHMAIL) += fetchmail
 package-$(BR2_COMPILE_FLAC) += flac
 package-$(BR2_PACKAGE_FPING) += fping
diff --git a/package/fakeidentd/Config.in b/package/fakeidentd/Config.in
new file mode 100644 (file)
index 0000000..ddfa3a9
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_FAKEIDENTD
+       prompt "fakeidentd........................ A static, secure identd."
+       tristate
+       default m if CONFIG_DEVEL
+       help
+         A static secure identd, only one source file.
+       
+         http://www.guru-group.fi/~too/sw/releases/
diff --git a/package/fakeidentd/Makefile b/package/fakeidentd/Makefile
new file mode 100644 (file)
index 0000000..fa61f35
--- /dev/null
@@ -0,0 +1,37 @@
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fakeidentd
+PKG_VERSION:=2.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=aa4133981c94c59868344cd3b02e8e19
+
+PKG_SOURCE_URL:=http://distfiles.gentoo.org/distfiles/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,FAKEIDENTD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) -o $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_BUILD_DIR)/identd.c
+       touch $@
+
+$(IPKG_FAKEIDENTD):
+       install -d -m0755 $(IDIR_FAKEIDENTD)/usr/sbin \
+                         $(IDIR_FAKEIDENTD)/etc/init.d \
+                         $(IDIR_FAKEIDENTD)/etc/default/
+       echo $(whoami) > $(IDIR_FAKEIDENTD)/etc/default/$(PKG_NAME)
+       $(CP) $(PKG_BUILD_DIR)/fakeidentd $(IDIR_FAKEIDENTD)/usr/sbin/
+       $(CP) ./files/$(PKG_NAME).init $(IDIR_FAKEIDENTD)/etc/init.d/$(PKG_NAME)
+       $(RSTRIP) $(IDIR_FAKEIDENTD)
+       $(IPKG_BUILD) $(IDIR_FAKEIDENTD) $(PACKAGE_DIR)
+
diff --git a/package/fakeidentd/files/fakeidentd.init b/package/fakeidentd/files/fakeidentd.init
new file mode 100644 (file)
index 0000000..954ad8c
--- /dev/null
@@ -0,0 +1,18 @@
+#!/bin/sh
+NAME=fakeidentd
+case "$1" in
+  start)
+       [ -e $DEFAULT ] && $NAME $DEFAULT
+       ;;
+  stop)
+        killall $NAME
+       ;;
+  restart)
+       killall $NAME
+       $NAME
+       ;;
+  *)
+       echo "Usage: $NAME (start|stop|restart)" > 2&
+       exit 1
+       ;;
+esac
diff --git a/package/fakeidentd/ipkg/fakeidentd.control b/package/fakeidentd/ipkg/fakeidentd.control
new file mode 100644 (file)
index 0000000..6c528b2
--- /dev/null
@@ -0,0 +1,4 @@
+Package: fakeidentd
+Description: A static, secure identd.
+Section: net
+Priority: optional
index ea24124..810345a 100644 (file)
@@ -1,4 +1,4 @@
-menu "weechat................................. Lightweight IRC client"
+menu "weechat........................... Lightweight IRC client"
 
 config BR2_PACKAGE_WEECHAT
        prompt "weechat.......................... Lightweight IRC client"