include: add a no dict version of lzma to new image build code
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:43:24 +0000 (11:43 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:43:24 +0000 (11:43 +0000)
Required to compress kernels in a brnboot compatible way.

Signed-off-by: Mathias Kresin <openwrt@kresin.me>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49240 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 7c11aa1..bc383e6 100644 (file)
@@ -336,7 +336,11 @@ define Build/fit
 endef
 
 define Build/lzma
-       $(STAGING_DIR_HOST)/bin/lzma e $@ -lc1 -lp2 -pb2 $(1) $@.new
+       $(call Build/lzma-no-dict,-lc1 -lp2 -pb2 $(1))
+endef
+
+define Build/lzma-no-dict
+       $(STAGING_DIR_HOST)/bin/lzma e $@ $(1) $@.new
        @mv $@.new $@
 endef