fix NO_TRACE_MAKE
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 12:16:26 +0000 (12:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 12:16:26 +0000 (12:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4205 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/verbose.mk

index 7d9b397..525fbf1 100644 (file)
@@ -6,13 +6,16 @@
 #
 # $Id:$
 
-export NO_TRACE_MAKE:=$(MAKE) V=99
+ifeq ($(NO_TRACE_MAKE),)
+NO_TRACE_MAKE := $(MAKE) V=99
+export NO_TRACE_MAKE
+endif
 
 ifndef KBUILD_VERBOSE
-  KBUILD_VERBOSE=0
-  ifeq ("$(origin V)", "command line")
-    KBUILD_VERBOSE=$(V)
-  endif
+  KBUILD_VERBOSE:=0
+endif
+ifeq ("$(origin V)", "command line")
+  KBUILD_VERBOSE:=$(V)
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)