openvpn: make size optimization configurable
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Mar 2014 12:07:17 +0000 (12:07 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Mar 2014 12:07:17 +0000 (12:07 +0000)
Signed-off-by: Christoph Kottke <christoph.kottke@gmx.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39872 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/openvpn/Config-nossl.in
package/network/services/openvpn/Config-openssl.in
package/network/services/openvpn/Config-polarssl.in
package/network/services/openvpn/Makefile

index 98cba25..3eaa228 100644 (file)
@@ -44,4 +44,11 @@ config OPENVPN_nossl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_nossl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
 endif
index 6686121..ac4c774 100644 (file)
@@ -56,4 +56,11 @@ config OPENVPN_openssl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_openssl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
 endif
index 64c4497..26692ce 100644 (file)
@@ -56,4 +56,11 @@ config OPENVPN_polarssl_ENABLE_IPROUTE2
        bool "Enable support for iproute2"
        default n
 
        bool "Enable support for iproute2"
        default n
 
+config OPENVPN_polarssl_ENABLE_SMALL
+       bool "Enable size optimization"
+       default y
+       help
+         enable smaller executable size (disable OCC, usage
+         message, and verb 4 parm list)
+
 endif
 endif
index f6c4381..a05248c 100644 (file)
@@ -66,7 +66,7 @@ CONFIGURE_VARS += \
 
 define Build/Configure
        $(call Build/Configure/Default, \
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --enable-small \
+               $(if $(CONFIG_OPENVPN_$(BUILD_VARIANT)_ENABLE_SMALL),--enable-small) \
                --disable-selinux \
                --disable-systemd \
                --disable-plugins \
                --disable-selinux \
                --disable-systemd \
                --disable-plugins \