various configure related cleanups
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 23:34:57 +0000 (23:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 23:34:57 +0000 (23:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6372 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/bridge/Makefile
package/dropbear/Makefile
package/e2fsprogs/Makefile
package/gmp/Makefile
package/ipsec-tools/Makefile
package/kexec-tools/Makefile
package/keynote/Makefile
package/libpcap/Makefile

index 0091af5..eb33bc3 100644 (file)
@@ -31,11 +31,7 @@ define Package/bridge
   URL:=http://bridge.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-linux-headers="$(LINUX_DIR)" \
-       )
-endef
+CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)"
 
 define Package/bridge/install
        $(INSTALL_DIR) $(1)/usr/sbin
index 9dba9f4..23e125e 100644 (file)
@@ -41,47 +41,26 @@ define Package/dropbearconvert
   TITLE:=Utility for converting SSH keys
 endef
 
+CONFIGURE_ARGS += \
+       --with-shared \
+       --disable-pam \
+       --enable-openpty \
+       --enable-syslog \
+       --disable-shadow \
+       --disable-lastlog \
+       --disable-utmp \
+       --disable-utmpx \
+       --disable-wtmp \
+       --disable-wtmpx \
+       --disable-loginfunc \
+       --disable-pututline \
+       --disable-pututxline \
+       --disable-zlib
+
 define Build/Configure
        $(SED) 's,^/\* #define PKG_MULTI.*,#define PKG_MULTI,g' $(PKG_BUILD_DIR)/options.h
        $(SED) 's,^#define DO_HOST_LOOKUP,/* & */,g' $(PKG_BUILD_DIR)/options.h
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --with-shared \
-                       --disable-pam \
-                       --enable-openpty \
-                       --enable-syslog \
-                       --disable-shadow \
-                       --disable-lastlog \
-                       --disable-utmp \
-                       --disable-utmpx \
-                       --disable-wtmp \
-                       --disable-wtmpx \
-                       --disable-loginfunc \
-                       --disable-pututline \
-                       --disable-pututxline \
-                       --disable-zlib \
-       );
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
index 1cbca85..1543a7b 100644 (file)
@@ -47,15 +47,12 @@ define Package/resize2fs
   DEPENDS:=e2fsprogs
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --enable-elf-shlibs \
-               --enable-dynamic-e2fsck \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-elf-shlibs \
+       --enable-dynamic-e2fsck
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/util \
index 5a58f8f..fa916f0 100644 (file)
@@ -29,13 +29,10 @@ define Package/libgmp
   URL:=http://www.swox.com/gmp/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static, \
-               CC="$(TARGET_CROSS)gcc" \
-       )
-endef
+CONFIGURE_VARS += CC="$(TARGET_CROSS)gcc"
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
 
 define Build/Compile
        $(call Build/Compile/Default, \
index 5951649..67772f1 100644 (file)
@@ -31,15 +31,7 @@ define Package/ipsec-tools
   URL:=http://ipsec-tools.sourceforge.net/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.ac \
-               aclocal.m4 \
-               Makefile.in \
-               config.h.in \
-               configure \
-       );
-       $(call Build/Configure/Default, \
+CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
                --with-kernel-headers="$(LINUX_DIR)/include" \
@@ -48,8 +40,17 @@ define Build/Configure
                --without-libradius \
                --without-libpam \
                --enable-dpd \
-               --enable-natt \
+               --enable-natt
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.ac \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
        );
+       $(call Build/Configure/Default)
 endef
 
 # override CFLAGS holding "-Werror" that break builds on compile warnings
index baad4fd..a537cdf 100644 (file)
@@ -33,31 +33,6 @@ define Package/kexec-tools
   URL:=http://www.xmission.com/~ebiederm/files/kexec/README
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/bin \
-                 --sbindir=/usr/sbin \
-                 --libexecdir=/usr/lib \
-                 --sysconfdir=/etc \
-                 --datadir=/usr/share \
-                 --localstatedir=/var \
-                 --mandir=/usr/man \
-                 --infodir=/usr/info \
-                 $(DISABLE_NLS) \
-                 $(DISABLE_LARGEFILE) \
-       );
-endef
-
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
index 264f163..9d97a96 100644 (file)
@@ -35,12 +35,9 @@ define Package/keynote
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-static \
-               --enable-shared \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
 
 define Build/Compile
        $(call Build/Compile/Default, \
index c33c034..20eb17e 100644 (file)
@@ -32,40 +32,13 @@ define Package/libpcap
   URL:=http://www.tcpdump.org/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-yydebug \
-                       --enable-ipv6 \
-                       --with-build-cc="$(HOSTCC)" \
-                       --with-pcap=linux \
-       );
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-yydebug \
+       --enable-ipv6 \
+       --with-build-cc="$(HOSTCC)" \
+       --with-pcap=linux
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \