oxnas: clean-up and improve profiles
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2016 20:14:31 +0000 (20:14 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2016 20:14:31 +0000 (20:14 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49198 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/oxnas/profiles/00-default.mk
target/linux/oxnas/profiles/cloudengines.mk [new file with mode: 0644]
target/linux/oxnas/profiles/pogoplug.mk [deleted file]

index fb04ba7..67f866e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,14 @@
 define Profile/Default
        NAME:=Default Profile
        PACKAGES:=\
-               kmod-usb-core kmod-usb3 \
-               kmod-ledtrig-usbdev
+               kmod-usb-core kmod-usb3 kmod-ledtrig-usbdev \
+               kmod-usb-storage \
+               kmod-i2c-gpio kmod-rtc-pcf8563 kmod-rtc-ds1307 \
+               kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
 endef
 
 define Profile/Default/Description
        Default package set compatible with most boards.
 endef
+
 $(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/cloudengines.mk b/target/linux/oxnas/profiles/cloudengines.mk
new file mode 100644 (file)
index 0000000..ed0a235
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/POGOPLUG_PRO
+  NAME:=Cloud Engines Pogoplug Pro
+endef
+
+define Profile/POGOPLUG_PRO/Description
+ Profile with built-in ox820 Pogoplug Pro device-tree
+ (board with miniPCIe slot)
+endef
+
+define Profile/POGOPLUG_V3
+  NAME:=Cloud Engines Pogoplug V3
+endef
+
+define Profile/POGOPLUG_V3/Description
+ Profile with built-in ox820 Pogoplug V3 device-tree
+ (board without miniPCIe slot)
+endef
+
+$(eval $(call Profile,POGOPLUG_PRO))
+$(eval $(call Profile,POGOPLUG_V3))
diff --git a/target/linux/oxnas/profiles/pogoplug.mk b/target/linux/oxnas/profiles/pogoplug.mk
deleted file mode 100644 (file)
index dcab128..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/POGOPLUG_PRO
-  NAME:=PogoPlug Pro
-endef
-
-define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
- (board with miniPCIe slot)
-endef
-
-define Profile/POGOPLUG_V3
-  NAME:=PogoPlug V3
-endef
-
-define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
- (board without miniPCIe slot)
-endef
-
-$(eval $(call Profile,POGOPLUG_PRO))
-$(eval $(call Profile,POGOPLUG_V3))