hostapd: remove old button hotplug script
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:53:07 +0000 (16:53 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:53:07 +0000 (16:53 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36991 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile

index 485a8fa..1c49451 100644 (file)
@@ -303,14 +303,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
 
 ifneq ($(LOCAL_TYPE),supplicant)
   define Package/hostapd-utils/install
 
 ifneq ($(LOCAL_TYPE),supplicant)
   define Package/hostapd-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/rc.button
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
-       $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
-       $(if $(CONFIG_PROCD_INIT),
-               $(INSTALL_DIR) $(1)/etc/rc.button/
-               $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
-               $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
-       )
+       $(INSTALL_BIN) ./files/wps-hotplug.sh $(1)/etc/rc.button/wps,
   endef
 endif
 
   endef
 endif