mac80211: fix intel wifi autoload module names
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2012 23:11:12 +0000 (23:11 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2012 23:11:12 +0000 (23:11 +0000)
The autoload directives were using wrong module names, preventing
them from being automatically inserted at boot time.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33676 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile

index 6b99d59..bdea68e 100644 (file)
@@ -636,7 +636,7 @@ define KernelPackage/iwlagn
   DEPENDS:= +kmod-mac80211 @PCI_SUPPORT
   TITLE:=Intel AGN Wireless support
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/iwlwifi/iwlwifi.ko
-  AUTOLOAD:=$(call AutoLoad,60,iwlagn)
+  AUTOLOAD:=$(call AutoLoad,60,iwlwifi)
   MENU:=1
 endef
 
@@ -712,7 +712,7 @@ define KernelPackage/iwl-legacy
   DEPENDS:= +kmod-mac80211 @PCI_SUPPORT
   TITLE:=Intel legacy Wireless support
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/iwlegacy/iwlegacy.ko
-  AUTOLOAD:=$(call AutoLoad,60,iwl-legacy)
+  AUTOLOAD:=$(call AutoLoad,60,iwlegacy)
 endef
 
 define KernelPackage/iwl-legacy/description