au1000: fix 3.18 and set it as default
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Feb 2015 09:49:38 +0000 (09:49 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 18 Feb 2015 09:49:38 +0000 (09:49 +0000)
Thanks to Bruno Randolf for testing and Manuel Lauss for providing a fix.

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44487 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/au1000/Makefile
target/linux/au1000/patches/005-fix-cpu-clk.patch [new file with mode: 0644]

index 0964561..7438e9b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
diff --git a/target/linux/au1000/patches/005-fix-cpu-clk.patch b/target/linux/au1000/patches/005-fix-cpu-clk.patch
new file mode 100644 (file)
index 0000000..b925638
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/mips/alchemy/common/clock.c
++++ b/arch/mips/alchemy/common/clock.c
+@@ -128,6 +128,8 @@
+               t = 396000000;
+       else {
+               t = alchemy_rdsys(AU1000_SYS_CPUPLL) & 0x7f;
++              if (alchemy_get_cputype() != ALCHEMY_CPU_AU1300)
++                      t &= 0x3f;
+               t *= parent_rate;
+       }