fix some wrong paths
authormatteo <matteo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 May 2008 22:08:46 +0000 (22:08 +0000)
committermatteo <matteo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 May 2008 22:08:46 +0000 (22:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11217 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/files/etc/init.d/fstab
package/util-linux-ng/Makefile

index b96e0c8..2d2976f 100755 (executable)
@@ -16,7 +16,7 @@ do_mount() {
        mkdir -p $target
        config_get_bool enabled "$cfg" "enabled" '1'
        [ "$enabled" -gt 0 ] && {
-         /bin/mount -t $fstype -o $options $device $target 
+               mount -t $fstype -o $options $device $target
        }
 }
 
@@ -25,8 +25,8 @@ do_swapon() {
        config_get device "$cfg" device
        [ -n "device" ] || return 0
        config_get_bool enabled "$cfg" "enabled" '1'
-       [ "$enabled" -gt 0 ] && [ -x /usr/sbin/swapon ] && {
-         /usr/sbin/swapon $device
+       [ "$enabled" -gt 0 ] && type swapon >/dev/null && {
+               swapon $device
        }
 }
 
@@ -36,7 +36,7 @@ do_unmount() {
        [ -n "target" ] || return 0
        config_get_bool enabled "$cfg" "enabled" '1'
        [ "$enabled" -gt 0 ] && {
-         /bin/umount $target 
+               umount $target
        }
 }
        
@@ -45,8 +45,8 @@ do_swapoff() {
        config_get device "$cfg" device
        [ -n "device" ] || return 0
        config_get_bool enabled "$cfg" "enabled" '1'
-       [ "$enabled" -gt 0 ] && [ -x /usr/sbin/swapoff ] && {
-         /usr/sbin/swapoff $device
+       [ "$enabled" -gt 0 ] && type swapoff >/dev/null && {
+               swapoff $device
        }
 }
 
index e15d555..f6593f7 100644 (file)
@@ -72,7 +72,7 @@ $(call Package/util-linux/Default)
 endef
 
 define Package/swap-utils/description
- This package contains a collection of tools for managing swap space: 
+ This package contains a collection of tools for managing swap space:
  - mkswap
  - swapon
  - swapoff
@@ -95,35 +95,34 @@ define Build/Compile
 endef
 
 define Package/fdisk/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/fdisk $(1)/sbin/
 endef
 
 define Package/cfdisk/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fdisk/cfdisk $(1)/sbin/
 endef
 
 define Package/losetup/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/losetup $(1)/sbin/
 endef
 
 define Package/mount-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/{u,}mount $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/{u,}mount $(1)/bin
 endef
 
 define Package/swap-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/mount/swapon $(1)/usr/sbin/
-       ln -sf swapon $(1)/usr/sbin/swapoff
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/disk-utils/mkswap $(PKG_BUILD_DIR)/mount/swapon $(1)/sbin/
+       ln -sf swapon $(1)/sbin/swapoff
 endef
 
 define Package/hwclock/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwclock/hwclock $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,fdisk))