[package] 6rd: apply the same simplifications done in 6to4 and 6in4
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jun 2012 23:08:20 +0000 (23:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 18 Jun 2012 23:08:20 +0000 (23:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32432 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6rd/Makefile
package/6rd/files/6rd.hotplug [deleted file]
package/6rd/files/6rd.sh

index 15b6e7a..3d45496 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=1
+PKG_VERSION:=2
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -48,8 +48,6 @@ define Package/6rd/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/6rdcalc $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/6rd.sh $(1)/lib/netifd/proto/6rd.sh
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
-       $(INSTALL_DATA) ./files/6rd.hotplug $(1)/etc/hotplug.d/iface/92-6rd
 endef
 
 $(eval $(call BuildPackage,6rd))
diff --git a/package/6rd/files/6rd.hotplug b/package/6rd/files/6rd.hotplug
deleted file mode 100644 (file)
index f38526c..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/bin/sh
-
-if [ "$ACTION" = ifup ]; then
-       . /lib/functions.sh
-
-       INCLUDE_ONLY=1
-       . /lib/netifd/proto/6rd.sh
-
-       include /lib/network
-       scan_interfaces
-
-       update_tunnel() {
-               local cfg="$1"
-
-               local proto
-               config_get proto "$cfg" proto
-               [ "$proto" = 6rd ] || return 0
-
-               local wandev
-               config_get wandev "$cfg" wan_device "$(find_6rd_wanif)"
-               [ "$wandev" = "$DEVICE" ] || return 0
-
-               local wanip=$(find_6rd_wanip "$wandev")
-
-               [ -n "$wanip" ] && ifup "$cfg"
-       }
-
-       config_foreach update_tunnel interface
-fi
index 3786ef0..d4dea36 100644 (file)
@@ -9,13 +9,6 @@
        init_proto "$@"
 }
 
-tun_error() {
-       local cfg="$1"; shift;
-
-       [ -n "$1" ] && proto_notify_error "$cfg" "$@"
-       proto_block_restart "$cfg"
-}
-
 proto_6rd_setup() {
        local cfg="$1"
        local iface="$2"
@@ -25,14 +18,17 @@ proto_6rd_setup() {
        json_get_vars mtu ttl ipaddr peeraddr ip6prefix ip6prefixlen ip4prefixlen
 
        [ -z "$ip6prefix" -o -z "$peeraddr" ] && {
-               tun_error "$cfg" "MISSING_ADDRESS"
+               proto_notify_error "$cfg" "MISSING_ADDRESS"
+               proto_block_restart "$cfg"
                return
        }
 
+       ( proto_add_host_dependency "$cfg" 0.0.0.0 )
+
        [ -z "$ipaddr" ] && {
                local wanif
                if ! network_find_wan wanif || ! network_get_ipaddr ipaddr "$wanif"; then
-                       tun_error "$cfg" "NO_WAN_LINK"
+                       proto_notify_error "$cfg" "NO_WAN_LINK"
                        return
                fi
        }