rename the Profile template that the image builder uses to prevent name conflicts...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Feb 2007 02:27:01 +0000 (02:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Feb 2007 02:27:01 +0000 (02:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6336 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/metadata.pl
target/imagebuilder/files/Makefile

index 7514a17..d27cd8e 100755 (executable)
@@ -151,7 +151,7 @@ sub gen_target_mk() {
     PACKAGES:=".join(" ", @{$profile->{packages}})."
   endef";
   $profiles_eval .= "
-\$(eval \$(call Profile,$conf\_$profile->{id}))"
+\$(eval \$(call AddProfile,$conf\_$profile->{id}))"
                }
                print "
 ifeq (\$(CONFIG_LINUX_$conf),y)
index eae3697..b36e2f2 100644 (file)
@@ -37,7 +37,7 @@ define Profile/Default
   PACKAGES:=
 endef
 
-define Profile
+define AddProfile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
   ifneq ($(ID),)