[include] uclibc++.mk: override the cc binary instead of the wrapper command when...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 Jun 2012 12:57:29 +0000 (12:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 Jun 2012 12:57:29 +0000 (12:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32383 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/uclibc++.mk

index 8174843..084ba6a 100644 (file)
@@ -8,5 +8,9 @@ PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
 CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
 
 ifneq ($(CONFIG_USE_UCLIBCXX),)
+ ifneq ($(CONFIG_CCACHE),)
+  TARGET_CXX_NOCACHE="g++-uc"
+ else
   TARGET_CXX="g++-uc"
+ endif
 endif