build: trigger pacakge index creation for all feeds if required
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 May 2015 11:37:05 +0000 (11:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 May 2015 11:37:05 +0000 (11:37 +0000)
When CONFIG_PER_FEED_REPO_ADD_DISABLED is set, trigger index creation for
any available feed, regardless of whether there where binaries built or not.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45765 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index 94b807f..a601dcb 100644 (file)
@@ -132,7 +132,11 @@ endif
 
 PACKAGE_SUBDIRS=.
 ifneq ($(CONFIG_PER_FEED_REPO),)
-  PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+    PACKAGE_SUBDIRS=base $(FEEDS_AVAILABLE)
+  else
+    PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  endif
 endif
 
 $(curdir)/index: FORCE