kernel: update 3.14 to 3.14.8
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jun 2014 12:27:36 +0000 (12:27 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jun 2014 12:27:36 +0000 (12:27 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41309 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.14/100-overlayfs.patch
target/linux/generic/patches-3.14/552-ubifs-respect-silent-mount-flag.patch
target/linux/generic/patches-3.14/831-ledtrig_netdev.patch
target/linux/kirkwood/patches-3.14/160-ea4500.patch
target/linux/x86_64/Makefile

index 926d2f3..8642314 100644 (file)
@@ -23,8 +23,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.7)
-  LINUX_KERNEL_MD5SUM:=046c448e477d534780ff7dad369b499f
+ifeq ($(LINUX_VERSION),3.14.8)
+  LINUX_KERNEL_MD5SUM:=d19dcd4819f2148cc85b80190133755e
 endif
 
 # disable the md5sum check for unknown kernel versions
 endif
 
 # disable the md5sum check for unknown kernel versions
index 28bd4d8..2983484 100644 (file)
  extern const struct file_operations pipefifo_fops;
 --- a/fs/namei.c
 +++ b/fs/namei.c
  extern const struct file_operations pipefifo_fops;
 --- a/fs/namei.c
 +++ b/fs/namei.c
-@@ -413,6 +413,7 @@ int __inode_permission(struct inode *ino
+@@ -414,6 +414,7 @@ int __inode_permission(struct inode *ino
  
        return security_inode_permission(inode, mask);
  }
  
        return security_inode_permission(inode, mask);
  }
  
  /**
   * sb_permission - Check superblock-level permissions
  
  /**
   * sb_permission - Check superblock-level permissions
-@@ -3035,9 +3036,12 @@ finish_open_created:
+@@ -3036,9 +3037,12 @@ finish_open_created:
        error = may_open(&nd->path, acc_mode, open_flag);
        if (error)
                goto out;
        error = may_open(&nd->path, acc_mode, open_flag);
        if (error)
                goto out;
index 8f7df0d..2e43d25 100644 (file)
@@ -22,11 +22,9 @@ Signed-off-by: Artem Bityutskiy <artem.bityutskiy@linux.intel.com>
 
 ---
 
 
 ---
 
-diff --git a/fs/ubifs/io.c b/fs/ubifs/io.c
-index e18b988..2290d58 100644
 --- a/fs/ubifs/io.c
 +++ b/fs/ubifs/io.c
 --- a/fs/ubifs/io.c
 +++ b/fs/ubifs/io.c
-@@ -988,30 +988,32 @@ int ubifs_read_node(const struct ubifs_info *c, void *buf, int type, int len,
+@@ -988,30 +988,32 @@ int ubifs_read_node(const struct ubifs_i
                return err;
  
        if (type != ch->node_type) {
                return err;
  
        if (type != ch->node_type) {
@@ -67,11 +65,9 @@ index e18b988..2290d58 100644
        return -EINVAL;
  }
  
        return -EINVAL;
  }
  
-diff --git a/fs/ubifs/super.c b/fs/ubifs/super.c
-index a81c7b5..3904c85 100644
 --- a/fs/ubifs/super.c
 +++ b/fs/ubifs/super.c
 --- a/fs/ubifs/super.c
 +++ b/fs/ubifs/super.c
-@@ -1149,6 +1149,9 @@ static int mount_ubifs(struct ubifs_info *c)
+@@ -1149,6 +1149,9 @@ static int mount_ubifs(struct ubifs_info
        size_t sz;
  
        c->ro_mount = !!(c->vfs_sb->s_flags & MS_RDONLY);
        size_t sz;
  
        c->ro_mount = !!(c->vfs_sb->s_flags & MS_RDONLY);
@@ -81,7 +77,7 @@ index a81c7b5..3904c85 100644
        err = init_constants_early(c);
        if (err)
                return err;
        err = init_constants_early(c);
        if (err)
                return err;
-@@ -1214,6 +1217,8 @@ static int mount_ubifs(struct ubifs_info *c)
+@@ -1214,6 +1217,8 @@ static int mount_ubifs(struct ubifs_info
        if (err)
                goto out_free;
  
        if (err)
                goto out_free;
  
@@ -90,8 +86,6 @@ index a81c7b5..3904c85 100644
        /*
         * Make sure the compressor which is set as default in the superblock
         * or overridden by mount options is actually compiled in.
        /*
         * Make sure the compressor which is set as default in the superblock
         * or overridden by mount options is actually compiled in.
-diff --git a/fs/ubifs/ubifs.h b/fs/ubifs/ubifs.h
-index e8c8cfe..c1f71fe 100644
 --- a/fs/ubifs/ubifs.h
 +++ b/fs/ubifs/ubifs.h
 @@ -51,6 +51,15 @@
 --- a/fs/ubifs/ubifs.h
 +++ b/fs/ubifs/ubifs.h
 @@ -51,6 +51,15 @@
index 6884346..1fdd6e8 100644 (file)
@@ -29,7 +29,7 @@
  #include <linux/netdevice.h>
  #include <linux/timer.h>
  #include <linux/ctype.h>
  #include <linux/netdevice.h>
  #include <linux/timer.h>
  #include <linux/ctype.h>
-@@ -307,8 +306,9 @@ done:
+@@ -294,8 +293,9 @@ done:
  static void netdev_trig_timer(unsigned long arg)
  {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
  static void netdev_trig_timer(unsigned long arg)
  {
        struct led_netdev_data *trigger_data = (struct led_netdev_data *)arg;
@@ -40,7 +40,7 @@
  
        write_lock(&trigger_data->lock);
  
  
        write_lock(&trigger_data->lock);
  
-@@ -318,7 +318,7 @@ static void netdev_trig_timer(unsigned l
+@@ -305,7 +305,7 @@ static void netdev_trig_timer(unsigned l
                goto no_restart;
        }
  
                goto no_restart;
        }
  
index a304e85..0abf1a1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -90,6 +90,7 @@
+@@ -90,6 +90,7 @@ dtb-$(CONFIG_ARCH_KIRKWOOD) += kirkwood-
        kirkwood-dns325.dtb \
        kirkwood-dockstar.dtb \
        kirkwood-dreamplug.dtb \
        kirkwood-dns325.dtb \
        kirkwood-dockstar.dtb \
        kirkwood-dreamplug.dtb \
index 3269f45..022ebd6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.7
+LINUX_VERSION:=3.14.8
 
 KERNELNAME:=bzImage
 
 
 KERNELNAME:=bzImage