brcm63xx: Add support for Comtrend VR-3025un
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jul 2014 17:44:48 +0000 (17:44 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Jul 2014 17:44:48 +0000 (17:44 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: José Vázquez Fernández <ppvazquezfer@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41848 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/etc/uci-defaults/09_fix_crc
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/563-board_VR-3025un.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch [new file with mode: 0644]

index 1d42d47..aa32099 100755 (executable)
@@ -81,6 +81,7 @@ DVG3810BN)
 96328A-1441N1 |\
 963281TAN |\
 963281T_TEF |\
+96368M-1341N |\
 96368M-1541N |\
 96368MVNgr |\
 "F@ST2504n" |\
index 7d9a6f7..9c966e7 100755 (executable)
@@ -19,6 +19,7 @@ case "$board_name" in
        963281TAN |\
        963281T_TEF |\
        96358-502V |\
+       96368M-1341N |\
        96368M-1541N |\
        96369R-1231N |\
        AW4339U |\
index 85d499e..74e6a0d 100755 (executable)
@@ -57,6 +57,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       96368M-1341N)
+               brcm63xx_has_reset_button="true"
+               status_led="VR-3025un:green:power"
+               ifname="eth0"
+               ;;
        96368M-1541N)
                brcm63xx_has_reset_button="true"
                status_led="VR-3025u:green:power"
index 01235e4..f36d182 100755 (executable)
@@ -232,6 +232,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96328A-1441N1,6328,AR-5387un,,--pad 8)
        # Comtrend VR-3025u
        $(call Image/Build/CFE,$(1),96368M-1541N,6368,VR-3025u,,--pad 16)
+       # Comtrend VR-3025un
+       $(call Image/Build/CFE,$(1),96368M-1341N,6368,VR-3025un,,--pad 4)
        # Comtrend WAP-5813n
        $(call Image/Build/CFE,$(1),96369R-1231N,6368,WAP-5813n,,--pad 4)
        # Davolink DV201AMR
diff --git a/target/linux/brcm63xx/patches-3.10/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.10/563-board_VR-3025un.patch
new file mode 100644 (file)
index 0000000..73d95e5
--- /dev/null
@@ -0,0 +1,109 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -4542,6 +4542,98 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_VR3025un = {
++      .name                                   = "96368M-1341N",
++      .expected_cpu_id                = 0x6368,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++
++      .has_enetsw                             = 1,
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "port1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "port2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "port3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "port4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name           = "VR-3025un:green:dsl",
++                      .gpio           = 2,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:inet",
++                      .gpio           = 5,
++              },
++              {
++                      .name           = "VR-3025un:green:lan1",
++                      .gpio           = 6,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:lan2",
++                      .gpio           = 7,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:lan3",
++                      .gpio           = 8,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:iptv",
++                      .gpio           = 9,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:power",
++                      .gpio           = 22,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "VR-3025un:red:power",
++                      .gpio           = 24,
++              },
++              {
++                      .name           = "VR-3025un:red:inet",
++                      .gpio           = 31,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 34,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++                      .active_low             = 1,
++              },
++      },
++};
++
+ static struct b53_platform_data WAP5813n_b53_pdata = {
+       .alias = "eth0",
+ };
+@@ -5018,6 +5110,7 @@ static const struct board_info __initcon
+       &board_96368mvwg,
+       &board_96368mvngr,
+       &board_VR3025u,
++      &board_VR3025un,
+       &board_WAP5813n,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
new file mode 100644 (file)
index 0000000..16350a3
--- /dev/null
@@ -0,0 +1,109 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -4552,6 +4552,98 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_VR3025un = {
++      .name                                   = "96368M-1341N",
++      .expected_cpu_id                = 0x6368,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++
++      .has_enetsw                             = 1,
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "port1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "port2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "port3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "port4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name           = "VR-3025un:green:dsl",
++                      .gpio           = 2,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:inet",
++                      .gpio           = 5,
++              },
++              {
++                      .name           = "VR-3025un:green:lan1",
++                      .gpio           = 6,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:lan2",
++                      .gpio           = 7,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:lan3",
++                      .gpio           = 8,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:iptv",
++                      .gpio           = 9,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "VR-3025un:green:power",
++                      .gpio           = 22,
++                      .default_trigger = "default-on",
++              },
++              {
++                      .name           = "VR-3025un:red:power",
++                      .gpio           = 24,
++              },
++              {
++                      .name           = "VR-3025un:red:inet",
++                      .gpio           = 31,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 34,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++                      .active_low             = 1,
++              },
++      },
++};
++
+ static struct b53_platform_data WAP5813n_b53_pdata = {
+       .alias = "eth0",
+ };
+@@ -5028,6 +5120,7 @@ static const struct board_info __initcon
+       &board_96368mvwg,
+       &board_96368mvngr,
+       &board_VR3025u,
++      &board_VR3025un,
+       &board_WAP5813n,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268