[package] uboot-envtools: update kirkwood scripts
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Oct 2013 19:46:43 +0000 (19:46 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Oct 2013 19:46:43 +0000 (19:46 +0000)
Also, scripts can be installed as data so let's change that here too.

Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38403 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/kirkwood

index b9c8461..4f03b92 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2013.07
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
@@ -55,27 +55,27 @@ define Package/uboot-envtools/install
        $(INSTALL_DATA) ./files/uboot-envtools.sh $(1)/lib
 ifneq ($(CONFIG_TARGET_ar71xx),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/ar71xx $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/ar71xx $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 ifneq ($(CONFIG_TARGET_cns3xxx),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/cns3xxx $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/cns3xxx $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 ifneq ($(CONFIG_TARGET_imx6),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/imx6 $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/imx6 $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 ifneq ($(CONFIG_TARGET_kirkwood),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/kirkwood $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 ifneq ($(CONFIG_TARGET_lantiq),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/lantiq $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 ifneq ($(CONFIG_TARGET_ramips),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_BIN) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
+       $(INSTALL_DATA) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
 endif
 endef
 
index cad53aa..f665d2d 100644 (file)
@@ -1,20 +1,17 @@
 #!/bin/sh
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2013 OpenWrt.org
 #
 
 [ -e /etc/config/ubootenv ] && exit 0
 
 touch /etc/config/ubootenv
 
-. /lib/kirkwood.sh
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
-hardware=$(kirkwood_hardware_name)
-
-case "$hardware" in
-"RaidSonic ICY BOX IB-NAS6210")
+case "`cat /proc/device-tree/model`" in
+"RaidSonic ICY BOX IB-NAS62x0 (Rev B)")
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
 esac