ramips: fix Asus WL-330N{, 3G} boards names
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:57:55 +0000 (05:57 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:57:55 +0000 (05:57 +0000)
There are other Asus boards supported in ramips target, so use the same naming scheme for WL-330N{,3G} boards and their dts files.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46615 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/WL-330N.dts [new file with mode: 0644]
target/linux/ramips/dts/WL-330N3G.dts [new file with mode: 0644]
target/linux/ramips/dts/WL_330N.dts [deleted file]
target/linux/ramips/dts/WL_330N3G.dts [deleted file]
target/linux/ramips/image/Makefile

diff --git a/target/linux/ramips/dts/WL-330N.dts b/target/linux/ramips/dts/WL-330N.dts
new file mode 100644 (file)
index 0000000..0e7c027
--- /dev/null
@@ -0,0 +1,100 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "WL-330N", "ralink,rt3050-soc";
+       model = "Asus WL-330N";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l3205d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l3205d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x3e>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               link {
+                       label = "asus:blue:link";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               power {
+                       label = "asus:blue:power";
+                       gpios = <&gpio0 11 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/WL-330N3G.dts b/target/linux/ramips/dts/WL-330N3G.dts
new file mode 100644 (file)
index 0000000..12a24b5
--- /dev/null
@@ -0,0 +1,109 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "WL-330N3G", "ralink,rt3050-soc";
+       model = "Asus WL-330N3G";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l3205d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "mx25l3205d";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x3e>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               3g {
+                       label = "asus:blue:3g";
+                       gpios = <&gpio0 9 1>;
+               };
+
+               3g2 {
+                       label = "asus:red:3g";
+                       gpios = <&gpio0 13 1>;
+               };
+
+               power {
+                       label = "asus:blue:power";
+                       gpios = <&gpio0 11 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
diff --git a/target/linux/ramips/dts/WL_330N.dts b/target/linux/ramips/dts/WL_330N.dts
deleted file mode 100644 (file)
index 14c78db..0000000
+++ /dev/null
@@ -1,100 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3050.dtsi"
-
-/ {
-       compatible = "WL_330N", "ralink,rt3050-soc";
-       model = "Asus WL-330N";
-
-       palmbus@10000000 {
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "mx25l3205d";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "mx25l3205d";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x3b0000>;
-                               };
-                       };
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x3e>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               link {
-                       label = "asus:blue:link";
-                       gpios = <&gpio0 9 1>;
-               };
-
-               power {
-                       label = "asus:blue:power";
-                       gpios = <&gpio0 11 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 10 1>;
-                       linux,code = <0x198>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 0 1>;
-                       linux,code = <0x198>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/WL_330N3G.dts b/target/linux/ramips/dts/WL_330N3G.dts
deleted file mode 100644 (file)
index aa4c547..0000000
+++ /dev/null
@@ -1,109 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3050.dtsi"
-
-/ {
-       compatible = "WL_330N3G", "ralink,rt3050-soc";
-       model = "Asus WL-330N3G";
-
-       palmbus@10000000 {
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "mx25l3205d";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "mx25l3205d";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x3b0000>;
-                               };
-                       };
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x3e>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               3g {
-                       label = "asus:blue:3g";
-                       gpios = <&gpio0 9 1>;
-               };
-
-               3g2 {
-                       label = "asus:red:3g";
-                       gpios = <&gpio0 13 1>;
-               };
-
-               power {
-                       label = "asus:blue:power";
-                       gpios = <&gpio0 11 1>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 10 1>;
-                       linux,code = <0x198>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio0 0 1>;
-                       linux,code = <0x198>;
-               };
-       };
-
-       otg@101c0000 {
-               status = "okay";
-       };
-};
index 6071ae7..949c05e 100644 (file)
@@ -631,9 +631,9 @@ Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))
 
 Image/Build/Profile/WIZARD8800=$(call BuildFirmware/Default8M/$(1),$(1),wizard-8800,WIZARD8800,Linux Kernel Image)
 
-Image/Build/Profile/WL_330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL_330N)
+Image/Build/Profile/WL-330N=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n,WL-330N)
 
-Image/Build/Profile/WL_330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL_330N3G)
+Image/Build/Profile/WL-330N3G=$(call BuildFirmware/Default4M/$(1),$(1),wl-330n3g,WL-330N3G)
 
 kernel_size_wl341v3=917504
 rootfs_size_wl341v3=2949120
@@ -763,8 +763,8 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WIZARD8800,$(1))
-       $(call Image/Build/Profile/WL_330N,$(1))
-       $(call Image/Build/Profile/WL_330N3G,$(1))
+       $(call Image/Build/Profile/WL-330N,$(1))
+       $(call Image/Build/Profile/WL-330N3G,$(1))
        $(call Image/Build/Profile/WL341V3,$(1))
        $(call Image/Build/Profile/WL-351,$(1))
        $(call Image/Build/Profile/WNCE2001,$(1))