ralink: add support for firewrt
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Jan 2015 06:34:28 +0000 (06:34 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Jan 2015 06:34:28 +0000 (06:34 +0000)
this is a mt7621 based board

Signed-off-by: wengbj <linux.c@foxmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44055 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/FIREWRT.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7621/profiles/firefly.mk [new file with mode: 0644]

index b440fb3..a8ed0b4 100755 (executable)
@@ -118,6 +118,7 @@ ramips_setup_interfaces()
        dir-300-b7 | \
        dir-320-b1 | \
        dir-615-h1 | \
+       firewrt | \
        hlk-rm04 | \
        mt7621 | \
        mt7628 | \
index 720b137..bb815da 100755 (executable)
@@ -91,6 +91,9 @@ ramips_board_detect() {
        *"Buffalo WSR-1166DHP")
                name="wsr-1166"
                ;;
+       *"Firefly FireWRT")
+               name="firewrt"
+               ;;
        *"CY-SWR1100")
                name="cy-swr1100"
                ;;
index 7c17211..ff7126a 100755 (executable)
@@ -50,6 +50,7 @@ platform_check_image() {
        f7c027 | \
        fonera20n | \
        freestation5 | \
+       firewrt |\
        hg255d | \
        hlk-rm04 | \
        ht-tm02 | \
diff --git a/target/linux/ramips/dts/FIREWRT.dts b/target/linux/ramips/dts/FIREWRT.dts
new file mode 100644 (file)
index 0000000..2e5d26b
--- /dev/null
@@ -0,0 +1,81 @@
+/dts-v1/;
+
+/include/ "mt7621.dtsi"
+
+/ {
+       compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+       model = "Firefly FireWRT";
+
+       memory@0 {
+               reg = <0x0 0x10000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       palmbus@1E000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "mx25l12805d";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x7b0000>;
+                               };
+
+                       };
+               };
+       };
+
+       pcie@1e140000 {
+               status = "okay";
+
+               pcie0 {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+
+               pcie1 {
+                       mt76@1,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x0000>;
+                               mediatek,5ghz = <0>;
+                       };
+               };
+       };
+};
index f935a95..e4dea9b 100644 (file)
@@ -893,7 +893,7 @@ endif
 #
 
 ifeq ($(SUBTARGET),mt7621)
-  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1
+  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt
 endif
 
 define Device/mt7621
@@ -925,6 +925,11 @@ define Device/dir-860l-b1
        seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb"
 endef
 
+define Device/firewrt
+  DTS := FIREWRT
+  IMAGE_SIZE := $(ralink_default_fw_size_8M)
+endef
+
 #
 # MT7628 Profiles
 #
diff --git a/target/linux/ramips/mt7621/profiles/firefly.mk b/target/linux/ramips/mt7621/profiles/firefly.mk
new file mode 100644 (file)
index 0000000..c8292b0
--- /dev/null
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Firefly
+       NAME:=Firefly Device
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 kmod-usb-hid  kmod-usb-storage mount-utils usbutils \
+        kmod-sdhci-mt7620 \
+               kmod-fs-ext3 kmod-fs-vfat kmod-fs-ntfs \
+               kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 \
+               kmod-ledtrig-usbdev \
+               kmod-ata-core \
+               luci \
+               kmod-mt76
+endef
+
+define Profile/Firefly/Description
+       Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Firefly))