OpenSSL: Added source/old to PKG_SOURCE_URL
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 15:07:40 +0000 (15:07 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Dec 2015 15:07:40 +0000 (15:07 +0000)
OpenSSL moves old versions of the library from
http://www.openssl.org/source/ to
http://www.openssl.org/source/old/$version/ breaking the old links.
That behavior breaks the OpenWRT-build every time OpenSSL releases
a new version.

This patch adds http://www.openssl.org/source/old/$version/ to the
PKG_SOURCE_URL of OpenSSL to avoid breaking the build whenever
OpenSSL releases a new version.

Signed-off-by: Kevin Kirsch <ranlvor@starletp9.de>
Reviewed-by: Alexander Dahl <post@lespocky.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47860 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/openssl/Makefile

index bbdd521..35ddc62 100644 (file)
@@ -8,7 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=1.0.2e
+PKG_BASE:=1.0.2
+PKG_BUGFIX:=e
+PKG_VERSION:=$(PKG_BASE)$(PKG_BUGFIX)
 PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
@@ -17,6 +19,7 @@ PKG_BUILD_PARALLEL:=0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.openssl.org/source/ \
+       http://www.openssl.org/source/old/$(PKG_BASE)/ \
        ftp://ftp.funet.fi/pub/crypt/mirrors/ftp.openssl.org/source \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=5262bfa25b60ed9de9f28d5d52d77fc5