make sure a predefined CFLAGS variable does not get in the way (fix for #4038)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Sep 2008 14:10:04 +0000 (14:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Sep 2008 14:10:04 +0000 (14:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12702 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk

index 06b0055..9d0eb25 100644 (file)
@@ -24,6 +24,9 @@ export REVISION
 export OPENWRTVERSION
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
+# make sure that a predefined CFLAGS variable does not disturb packages
+export CFLAGS=
+
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
 endif