add target package/target_name to the master makefile, which will run $(MAKE) -C...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Jun 2005 14:05:22 +0000 (14:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Jun 2005 14:05:22 +0000 (14:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1147 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index e935295..1b8d968 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
 #
 #############################################################
 
-
 # In this section, we need .config
 include .config.cmd
 
@@ -108,6 +107,16 @@ $(BUILD_DIR):
 
 source: $(TARGETS_SOURCE)
 
+
+package/%:
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
 #############################################################
 #
 # Cleanup and misc junk