kernel: make sure that packages are generated for built-in crypto modules to avoid...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jan 2013 17:09:16 +0000 (17:09 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Jan 2013 17:09:16 +0000 (17:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35158 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk

index 221b5a0..6a3b5a6 100644 (file)
@@ -15,7 +15,7 @@ CRYPTOMGR_MODULES = \
        BLKCIPHER2=crypto_blkcipher
 
 crypto_confvar=CONFIG_CRYPTO_$(word 1,$(subst =,$(space),$(1)))
-crypto_file=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko)
+crypto_file=$(LINUX_DIR)/crypto/$(word 2,$(subst =,$(space),$(1))).ko
 crypto_name=$(if $(findstring y,$($(call crypto_confvar,$(1)))),,$(word 2,$(subst =,$(space),$(1))))
 
 define KernelPackage/crypto-core