kernel/modules: add kmod-ip6-vti
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 08:30:09 +0000 (08:30 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2016 08:30:09 +0000 (08:30 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48703 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index cbf2ffb..77bd67a 100644 (file)
@@ -420,6 +420,22 @@ endef
 $(eval $(call KernelPackage,ip-vti))
 
 
+define KernelPackage/ip6-vti
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=IPv6 VTI (Virtual Tunnel Interface)
+  DEPENDS:=+kmod-iptunnel +kmod-ip6-tunnel +kmod-ipsec6
+  KCONFIG:=CONFIG_IPV6_VTI
+  FILES:=$(LINUX_DIR)/net/ipv6/ip6_vti.ko
+  AUTOLOAD:=$(call AutoLoad,33,ip6_vti)
+endef
+
+define KernelPackage/ip6-vti/description
+ Kernel modules for IPv6 VTI (Virtual Tunnel Interface)
+endef
+
+$(eval $(call KernelPackage,ip6-vti))
+
+
 define KernelPackage/iptunnel4
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv4 tunneling