include the default profile in target.mk as well - required for the image builder...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jan 2007 21:44:13 +0000 (21:44 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jan 2007 21:44:13 +0000 (21:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6098 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/metadata.pl

index 5da5ac4..9434af0 100755 (executable)
@@ -46,6 +46,15 @@ sub parse_target_metadata() {
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
        }
+       foreach my $target (@target) {
+               @{$target->{profiles}} > 0 or $target->{profiles} = [
+                       {
+                               id => 'Default',
+                               name => 'Default',
+                               packages => []
+                       }
+               ];
+       }
        return @target;
 }
 
@@ -274,13 +283,6 @@ EOF
        foreach my $target (@target) {
                my $profiles = $target->{profiles};
                
-               @$profiles > 0 or $profiles = [
-                       {
-                               id => 'Default',
-                               name => 'Default',
-                               packages => []
-                       }
-               ];
                foreach my $profile (@$profiles) {
                        print <<EOF;
 config LINUX_$target->{conf}_$profile->{id}